• 0

    posted a message on [Wildstar] Lockdown
    Quote from Llama jump

    Ok sorry for my incompetence but is there a dummy guide to get this game to play like tera? I installed lockdown and its running fine but I'm lost when it comes to how to make my LMB and RMB use skills in combat. I've downloaded and installed AHK like the curse website says but how do I use it? step 2 says 

    Run Addons\Lockdown\MouselockRebind.ahk (This has changed!)

    where is this addons folder?

     I would also like to set my mouse button 4 (which is one of the two near my thumb) to activate/deactivate cursor mode.

    Any help for this newby would be great thanks

     If you installed with the Curse client, you right click on Lockdown in the list, and find the option to open the folder for the addon. It is actually located in %appdata%\ncsoft\wildstar\addons IIRC

     

    Once you do that you're basically there as far as being ready to use. You seem like you're already following the documentation which is good.

     

    Also: There is no support for directly binding to Mouse4/5 unfortunately, due to how I handle keypresses. If your mouse software can remap it, you can map it to a key and use that key.

     

    If that fails, I might be able to do something for you with the AHK (That's kind of what it is good at)

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    My initial testing with build z24a indicates that things are working flawlessly.   Awesome!  So happy right now.  Thank you!

    Good news =)

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »
    Quote from Xuerian »
    Quote from mbmilford »

    With the latest update I can confirm the targeting is still broken after taking a drop ship. I will test with the entrance to DS tomorrow night and report back.

    With z24? Really?

    It instantly worked fine with me after I figured out the problem. :\

    OK, this is what I am experiencing with version z24:

     

    Upon initially loading the game, the targeting does not work. But after 1 /reloadui, the targeting is fixed including after taking a drop ship, etc.

    That's annoying, but thankfully easy to fix. z24a should work fine.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    With the latest update I can confirm the targeting is still broken after taking a drop ship. I will test with the entrance to DS tomorrow night and report back.

    With z24? Really?

    It instantly worked fine with me after I figured out the problem. :\

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »
    Quote from Xuerian »
    Quote from mbmilford »

    Would it be possible for Lockdown to call a /reloadui each time one of these happens:

    i) a ship is taken

    ii) a teleporter is used

    iii)you zone into an adventure/dungeon ?

    This would not be optimal, but it would fix the problem.

    Not optimal at all. The problem is, I'm not having any luck reproducing the issue now. I've had it myself, but I can't reproduce it. 

    I'll let you know if I figure anything out.

    Edit: Also, back for Drop 4.

    Any luck reproducing the bug?

    Pretty sure I got it this time. 

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Any luck reproducing the bug?

    Sort of. Nothing solid yet, I haven't determined what it is. Like you said, taking a dropship tends to trigger it, but from what I've seen and can tell so far it just breaks some units not all. 

    I'll be working on it more in the coming days, but it'll involve rigging it up for debugging in ways that isn't necessarily hard, but is annoying.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Also, I am having another issue.  I am trying to run another .ahk script along with MouseLockRebind.ahk, but somehow Lockdown/MouseLockRebind.ahk cause my .ahk to stop working.

     The script presses F7 while I have my left mouse button pressed.   I am using Lockdown to bind left mouse to action bar 1, so I think there is some kind of conflict.  It also seems to somehow be affected by the shift key.

     I tried to just add my script to MouseLockRebind.ahk, but MouseLockRebind.ahk appears as one big block of text in notepad making it very hard to read.  Placing my script at the end of MouseLockRebind.ahk broke Lockdown.

     Would it even be possible to add something like this to MouseLockRebind.ahk?  If so, where should I place it?  And what program should I use to make MouseLockRebind.ahk appear formatted?

    ~LButton::
    while GetKeyState("LButton", "P") ; While the LButton key is being held down physically.
    {
    SendInput {F7}
    Sleep 200
    }
    return

    Again, big thanks and glad your back!

    No one else seems to be working on anything like Lockdown anymore, so I am very excited that I will be able to keep playing the game the way I want!

    I work in Sublime Text, but Notepad++ is the common choice. 

    Lockdown already has a aggressive LMB handler, you'll want to integrate yours into it if you want it to work, but unfortunately I'm not going to provide any support for non 1-to-1 actions in Lockdown myself - for what I hope are obvious reasons.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Would it be possible for Lockdown to call a /reloadui each time one of these happens:

    i) a ship is taken

    ii) a teleporter is used

    iii)you zone into an adventure/dungeon ?

    This would not be optimal, but it would fix the problem.

    Not optimal at all. The problem is, I'm not having any luck reproducing the issue now. I've had it myself, but I can't reproduce it. 

    I'll let you know if I figure anything out.

    Edit: Also, back for Drop 4.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Is there anything I can do to help get the targeting fixed after taking a ship?

    Ah, right, you're that guy.

    At this point, yes, there is something you can do: You can go here: https://forums.wildstar-online.com/forums/index.php?/topic/61277-api-issues-still-a-problem-gamelibsetmouselock-and-needed-api-calls/

    Bump it. Do whatever you want to it. That is the functionality I need to not have to cheese targeting. The targeting in Lockdown now is a dirty hack that I really shouldn't have to do. It's entirely unsurprising that it breaks repeatedly due to how carbine handles units. 

    If I get a chance I will get you that debug version I mentioned. As of yet, I haven't made the modifications for it, and still have no way to test it because I'm neither subscribed Wildstar nor want to be based on its current trajectory.

    I would love for it to work and regret that it breaks at this point in the game for you. 

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Is this still being updated?

    I am no longer playing, but as far as I know it should still work for the most part. Very little is changing in Wildstar's UI. 

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    Ok,so actually I was wrong again.  Sorry it took so long to respond but I was in raid.

    I tried this with Slim Unit Frames, PotatoUI, and  the default Carbine unit frames.  Lockdown will target with the reticle correctly, until you zone or die.  Then it will still show the red or yellow "aura" around the enemy the reticle is on, but the unit frame of the target will not be displayed. Reloadui fixes the problem temporarily.

    The red and yellow "aura" is from Wildstar's mouseover with the real mouse cursor, which would be nice to use, but I can't since carbine doesn't let us move where it locks at.

    The reticle is actually an entirely separate system based off the radius and position of reticle you've picked. 

    Pretty much the only way for me to fix this at this point is if you can 100% repeat getting Lockdown to stop targeting things, and tell me the minimum amount to do it. 

    Also try things like toggling lockdown on and off via key and see if that effects it.

    Once you narrow down the reproduction, I can either fix it or provide you with a debug build to gather more information.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    You were right, it does. For some reason slim unit frame no longer works properly with this.  When using the default unit frames, the target's unit frame shows up when I place the reticle on them.  Thanks!

    I don't know how that can happen, to be honest. They shouldn't interact. But I haven't looked at Slim, so.. it could be doing anything.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from mbmilford »

    I can't seem to get the reticle targeting to work?  I have the reticle targeting option checked and only hostile selected.   But, when I place the reticle over an enemy, it does not target them. I have been using Lockdown for months and I swear it used to have this functionality.

    It should work. I can't test it at this point though, I have no active sub.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from Tadewing »

    Every time I mount I get self-targeted until pressing ESC. Does not happen with addon disabled or when mouse lock is off, but as soon as you toggle lock your character gets targeted again.

    Try this: Toggle lockdown off, mount up, toggle lockdown on.

    I've had a major problem trying to avoid this one for some no-good reason. Wildstar does mounts really weird, technically they're a separate unit (I guess so they can have health/soak abilities), but it causes a lot of annoyance when messing with targeting.

    Posted in: Addons
  • 0

    posted a message on [Wildstar] Lockdown
    Quote from Resisol »

    Wow, thanks a lot mate, very much appreciated. You got the modified version up before we played this evening :-)

    I got my friend to install the modified version and it workd perfectly! She was *so* chuffed, it's made a huge difference to her enjoyment of the game.

    Thanks again!

     

    Well, that's good news. Glad it's working out. It should work fine until I make any more changes at least, which isn't likely to be until I'm playing again, at which point I'll try to make it an option. Enjoy =)

    Posted in: Addons
  • To post a comment, please or register a new account.